“Unable to locate package” error in Kali Linux (Fixed)

Hello guys,

If you are using kali linux  , you may be familiar with that error “Unable to locate package” .

What does it mean?

It means that the package/program/app that you are trying to install doesn’t have responsibilities i the  responsibility files in other simpler words there is no resource links for it.

How to fix it ?

[This post is written on the 14th of August 2019  .Till now that solutions works very well  .]

 

Go to /etc/apt/

 

Open the file sources.list  by any text-editor

(It is better to take a copy of it as a backup)

then paste the following code at the last line of the file:

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali kali-rolling main contrib non-free
deb http://http.kali.org/kali sana main non-free contrib
deb http://security.kali.org/kali-security sana/updates main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali sana main non-free contrib
# deb-src http://security.kali.org/kali-security sana/updates main contrib non-free
deb http://old.kali.org/kali moto main non-free contrib
# For source package access, uncomment the following line
# deb-src http://old.kali.org/kali moto main non-free contrib
=======
Then save and close the file.
After that we will get the updates

 sudo apt-get update  Now you can install your package without any errors. Thanks 

 

Follow US

Leave a Reply